Help. PSP 2003 buttons not responding in XMB.


Hi. I bought a faulty PSP which hangs the moment it got into the XMB menu after booting up. I tried getting into the recovery menu and all the buttons worked fine when i was in the recovery menu. it's using 5.00m33 cfw. I've tried Hellcats recovery flasher but the buttons stopresponding the moment it entered hellcat mode. seems like the button only worked during recovery menu.
can someone tell me what is wrong with it and how to fix it?
Our free community is dedicated to US-based video gamers to provide a platform for exchange and support.
Join discussions on cheating, guides, exploits & tips, secrets, mods and so much more!
PSA: we do not support cheating for online/mobile/multiplayer games, which may include trainers,
mod menu's, Exploits, Hacks, Tools & Macros, Bots and so on. (we do allow the posting of such for offline/single player games hoewever, online and multiplayer games is where we draw the line. Phone apps/games for example typically offer a storefront to purchase ingame currency for example; whether it's singleplayer or not, in such games, the aforementioned is not allowed.)
Top Bottom