PSP 1000 5.00 M33-6 Stopped Running Games and Homebrew


Hi guys, I have been a happy PSP 1000 owner since the 1.50 .tiff exploit. I have been upgrading fairly often till 5.00 M33-6, and I left it at that as it did everything I wanted. After that I just used my PSP for movies.

However, I recently I tried to play some newer games that required me to installed Prometheus 4. So this morning I grabed the files from another site and tried to install it. It gave me an error (I forgot, it was something like 8xxxxxc) so I went to another site and grabbed that. However, a few hours later, I discovered that my PSP had stopped playing EVERYTHING. Homebrew, ISO's, etc. I can't even run Hellcat's flasher from the recovery.

My problem: Whenever I load up a UMD, ISO, Homebrew APP, I stay on the white "PSP" Screen for 5 seconds or so and then it goes to black for 10 seconds, and then turns off.
However, My UMD demo disc's Movies and music work.

I have tried disabling all plugins, reformatting one of my Genuine Sandisk memory cards, M33 drive, different battery

Does anyone know what's up with my PSP?

Thanks in advance!
Our free community is dedicated to US-based video gamers to provide a platform for exchange and support.
Join discussions on cheating, guides, exploits & tips, secrets, mods and so much more!
PSA: we do not support cheating for online/mobile/multiplayer games, which may include trainers,
mod menu's, Exploits, Hacks, Tools & Macros, Bots and so on. (we do allow the posting of such for offline/single player games hoewever, online and multiplayer games is where we draw the line. Phone apps/games for example typically offer a storefront to purchase ingame currency for example; whether it's singleplayer or not, in such games, the aforementioned is not allowed.)
Top Bottom