problems upgrading to 5.50 GEN-D3

Cloud

Moderator
Good Evening everyone,

Recently I tried the 5.50 GEN-D3 update on my PSP. The PSP is a 1004 series, is fully charged, and I currently have the official v5.02 firmware. So, I place all of the files in the folders as said in the instructions, but when I try to launch the update on the PSP I get the following message:

"This game cannot be started. The data is corrupted"

I then tried other copies of the update from different sites, and the same thing happened with all of them. I tried to search this bug up on Google, but showed up nothing relevant. There were some posts about corrupted gamesaves, but I think that applies to when the update is actually installed.

Are there any suggestions on what I could do, or how to fix this issue?
 
Our free community is dedicated to US-based video gamers to provide a platform for exchange and support.
Join discussions on cheating, guides, exploits & tips, secrets, mods and so much more!
PSA: we do not support cheating for online/mobile/multiplayer games, which may include trainers,
mod menu's, Exploits, Hacks, Tools & Macros, Bots and so on. (we do allow the posting of such for offline/single player games hoewever, online and multiplayer games is where we draw the line. Phone apps/games for example typically offer a storefront to purchase ingame currency for example; whether it's singleplayer or not, in such games, the aforementioned is not allowed.)
Back
Top Bottom