New DC game wont boot

Chat about the Sega Dreamcast and get cheat codes for it in the subforums.


Vgcheat Member
Very strange this issue. I bought me a new fresh copy of ghost blade and this new game won't boot in my Japanese modded console. I tried the laser adjust method and I even ripped and burned it to a second cd, still no play.
It shows the Sega logo, the game logo and then it just bounces back to the Sega logo.
All my other games, US, Japanese and PAL they work like a charm. Even if discs are heavily scratched.

Sent from my iPhone using Tapatalk
Our free community is dedicated to US-based video gamers to provide a platform for exchange and support.
Join discussions on cheating, guides, exploits & tips, secrets, mods and so much more!
PSA: we do not support cheating for online/mobile/multiplayer games, which may include trainers,
mod menu's, Exploits, Hacks, Tools & Macros, Bots and so on. (we do allow the posting of such for offline/single player games hoewever, online and multiplayer games is where we draw the line. Phone apps/games for example typically offer a storefront to purchase ingame currency for example; whether it's singleplayer or not, in such games, the aforementioned is not allowed.)
Top Bottom