Command Button Malfunction, PSP Slim


Guys, I'm new here and I badly need your help.

Two days ago, I was playing with my PSP slim. Suddenly, command buttons (square, triangle, x and circle) buttons don't work. I tried hard resetting and removing the battery, and still the buttons didn't work on the XMB. I also tried running the PSP on the recovery mode, but there is still no response from the said buttons.

Other buttons are functional (start, select, home, volume, sound, L and R triggers and backlight). What should I do? Is this a software or a hardware problem?

*note: I wasn't able to check my firmware version, since the buttons are not functional.

Thanks in advance.
Have a good day. :)
Our free community is dedicated to US-based video gamers to provide a platform for exchange and support.
Join discussions on cheating, guides, exploits & tips, secrets, mods and so much more!
PSA: we do not support cheating for online/mobile/multiplayer games, which may include trainers,
mod menu's, Exploits, Hacks, Tools & Macros, Bots and so on. (we do allow the posting of such for offline/single player games hoewever, online and multiplayer games is where we draw the line. Phone apps/games for example typically offer a storefront to purchase ingame currency for example; whether it's singleplayer or not, in such games, the aforementioned is not allowed.)
Top Bottom