Cladun: This is an RPG! 80020148 error



I was going to start playing Cladun when I was greeted by this nasty error. After some googling i tried a few basic things like switching my UMD driver, enabling some advanced options etc.
Now the tricky thing is I have played this game before, this exact image on this exact PSP. So I know it's not an issue with my iso or anything of the like (and I've copied it over a few times just to check if maybe something went wrong when I put it on the memory stick)
Since I last played Cladun I have fiddled a bit with the firmware, I used to have 5.50 prome 4, and then i saw all this newfangled 6.20 stuff and tried that out, it wasn't to my taste so I went back to 5.50 prome-4 and until now everything has been cherry. I've been playing ISOs various homebrews and recently beat Mega Man Legends 2 (curse that Flutter glitch!)

Any advice would be greatly appreciated since I'd love to play this lovely game.

I have an old phat PSP running 5.50 prometheus-4
things I have tried so far include:
changing UMD driver, enabling/disabling plugins, formatting flash1, enabling/disabling plain modules and execute BOOT>BIN options

Thanks a bunch
Our free community is dedicated to US-based video gamers to provide a platform for exchange and support.
Join discussions on cheating, guides, exploits & tips, secrets, mods and so much more!
PSA: we do not support cheating for online/mobile/multiplayer games, which may include trainers,
mod menu's, Exploits, Hacks, Tools & Macros, Bots and so on. (we do allow the posting of such for offline/single player games hoewever, online and multiplayer games is where we draw the line. Phone apps/games for example typically offer a storefront to purchase ingame currency for example; whether it's singleplayer or not, in such games, the aforementioned is not allowed.)
Top Bottom