d3to

  1. C

    Tips for upgrading 5.50 gen d3to the latest firmware

    Hi bros, Please kindly assist to my request. Can I go for cfw 6.39 ME-9 straight? Or I need to update to 6.20? I read the post that lcfw 6.39 LME-9 is just a launcher. Im needed to launch it whenever I restart my psp right? Would appreciate your help, Thanks! Robin
Back
Top Bottom